cisco路由器PPPOE+NAT+DHCP

DHCP:给客户端

ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool test
import all
network 192.168.1.0 255.255.255.0
dns server 202.106.0.20
default-router 192.168.1.1

接口配置:

interface GigabitEthernet0/0/0 –接adsl
no ip address
negotiation auto
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface GigabitEthernet0/0/1 —-接内网
ip address 192.168.1.1 255.255.255.0
ip nat inside
shutdown
negotiation auto

拨号器:

interface Dialer1
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp chap hostname 1231232131(宽带账号名)
ppp pap sent-username 1231232131(宽带账号名) password 7 123123123(宽带密码)
Nat设置:

ip route 0.0.0.0 0.0.0.0 Dialer1 -默认路由
!
!
access-list 1 permit 192.168.1.0 0.0.0.255

ip nat inside source list 1 interface Dialer1 overload

1 条评论

  • eeli 2015年12月19日 回复

    OH,GOOD BLOG.

发表评论

电子邮件地址不会被公开。 必填项已用*标注